Everything in the web browser is bold — or italic

Hello, my faithful followers! I am back; after a long hiatus, I am back again.

Not long ago, I encountered an issue in a laptop computer running Windows 7 Professional edition (x64). Internet Explorer running on the computer displayed all letters in web pages in bold typeface while Google Chrome displayed them all in italic typeface. Of course, the issue did not reproduce in all websites. For example, Microsoft.com was alright but Google.com and Wikipedia.org were not.

I installed Mozilla Firefox on that computer. In Mozilla Firefox, everything was in bold typeface.

Wordpad

Screenshot of Wordpad: Although I have not select bold button, the text is written in bold typeface.

I decided that since this issue was reproduced in three independent web browsers, then the browsers and their settings are not to blame. And since the issue did not occur on all websites, then there should be something amiss with the font itself, especially because I knew that Google and Wikipedia were using Arial (a default font that comes with Windows). Arial is the default sans-serif font of Mozilla Firefox. Therefore, I changed the default sans-serif font of Firefox to Calibri and this resolved the issue. Then, I opened Wordpad (a component of Windows 7) and tried to write in Arial font. Result: It was in bold typeface.

An investigation in Fonts folder of Control Panel showed that Arial Regular was not on the system. (Something must have deleted it.) Fortunately, there was a Windows 7 backup nearby, from which I extracted Arial Regular and installed it on the system.

Today, I encountered a similar issue on the same laptop. Boot Configuration Data Editor Frequently Asked Questions (part of Microsoft website) was all in bold typeface. I used a developer tool to inspect the page and discover that the web page was using Verdana. (I do not remember which developer toolset; however, Internet Explorer and Google Chrome come with built-in developer tools. Firefox also has an add-on called Firebug that I always install. These three are all activated by pressing F12 key.) Verdana Regular was absent from the system. I managed to install it by recovering it from another copy of Windows 7 Professional installed in another partition.

Advertisements

Posted on 14 July 2011, in Windows Administration. Bookmark the permalink. Leave a comment.

Leave a comment

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: